PRUEBAS DE ESCRITORIO

 

3.5   PRUEBAS DE ESCRITORIO


La prueba de escritorio es una herramienta útil para entender que hace un determinado algoritmo, o para verificar que un algoritmo cumple con la especificación sin necesidad de ejecutarlo.

Básicamente, una prueba de escritorio es una ejecución ‘a mano’ del algoritmo, por lo tanto se debe llevar registro de los valores que va tomando cada una de las variables involucradas en el mismo.

A continuación se muestra un ejemplo de prueba de escritorio del siguiente algoritmo:

suma :entero
entrada :entero
menor :entero

leer entrada
menor = entrada
suma = 0
mientras (entrada != 0) haga
si (entrada < menor) entonces
menor =entrada
fin_si
suma = suma + entrada
leer entrada
fin_mientras
escribirvalor Menor:
escribir menor
escribir Suma:
escribir suma

tr>
INSTRUCCIÓN
entrada
menor
suma
Pantalla
leer entrada
10
     
menor = entrada  
10
   
suma :=0    
0
 
suma :=suma + entrada    
10
 
leer entrada
7
     
menor = entrada  
7
   
suma :=suma + entrada    
17
 
leer entrada
9
     
suma :=suma + entrada    
26
 
leer entrada
0
     
Escribir valor menor:      
Valor Menor
Escribir menor      
7
Escribir Suma:      
Suma:
Escribir suma      
26

 



Universidad Nacional de Colombia
Carrera 30 No 45-03 - Edificio 477
Bogotá D.C. - Colombia

Aviso Legal - Copyright
Gobierno en LíneaAgencia de Noticias UN